Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 17, 2024 - 07:00 UTC
Scheduled
We will upgrade our BI servers during this maintenance slot. Analytics dashboard won't be available, while the rest of the application will be up and running.
Posted Dec 11, 2024 - 16:08 UTC
This scheduled maintenance affected: Production environment.